Не отображается процесс загрузки (РЕШЕНО)

Всё, что не по теме форума -- сюда
Ответить
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

Приветствую форум!
Загрузчиком системы является systemd-boot. В опциях загрузки не указан quiet .
Сначала не обращал внимания. После обновления системы при перезагрузке, сначала черный экран, затем два пика и через несколько секунд включается монитор и на экране сразу окно входа sddm для ввода пароля. Для сведения : комп никогда не выключаю, уже несколько лет (только для чистки от пыли и профилактики).
Загрузочным диском является NVMe. На втором диске обычном ССД стоит винда и при перезагрузке можно было выбрать из загрузочных записей или арч или винду.
Можно попробовать в /etc/systemd/system.conf убрать решётку перед
  • systemd.show_status=yes
, но по коду ощибки по #15398 указано " systemd-boot не показывает загрузочные записи, определенные в расширенном загрузочном разделе, когда загрузочным диском является NVMe #15398 ". https/github.com/systemd/systemd/issues/15398.
Виндой не пользуюсь, но через выбор диска по F11 или F12 (не помню какую нажимать) видимо выбрать смогу, а раньше выбор был через systemd-boot.
Вопрос - это только у меня с NVMe не отображается процесс загрузки системы ?
Последний раз редактировалось beisic 02.12.2023 10:12, всего редактировалось 1 раз.
vall
Аватара пользователя
Администрация
Сообщения: 517
Зарегистрирован: 09.08.2022

#

Хотя проблема и закрыта https://github.com/systemd/systemd/issues/15398 , но вопрос имел место быть. И в обсуждении всё не очевидно (для меня).

Сегодня проверил. У меня на ноутбуке GRUB (efi, NVMe) и ради интереса убрал параметр quiet. Ничего не изменилось. Загрузочные записи так и не появились. Сразу же sddm.

P.S.
И для разнообразия ) На десктопе GRUB (MBR, SSD) без параметра quiet загрузочные записи отображаются как обычно.
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

Спасибо за ответ.
Вывод - вне зависимости от загрузчика systemd-boot или GRUB, загрузочные записи не отображаются только для дисков NVMe..
ALiEN
Аватара пользователя
Сообщения: 58
Зарегистрирован: 23.08.2022

#

Как вариант, загрузка очень быстро проскакивает, монитор попросту не успевает переключиться в нужный режим и отобразить лог загрузки.

🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

ALiEN
Аватара пользователя
Сообщения: 58
Зарегистрирован: 23.08.2022

#

В хуках initcpio kms присутствует? В modules есть модуль видеокарты (при kms вроде как не нужно, но всё же...)?

🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

beisic ~ $ mkinitcpio -L
==> Available hooks
autodetect consolefont haveged kms memdisk sd-encrypt shutdown udev
base encrypt hostdata lvm2 modconf sd-lvm2² sleep usr
block filesystems keyboard mdadm¹ ostree sd-shutdown strip
btrfs fsck keymap mdadm_udev resume sd-vconsole systemd

'¹' This hook is deprecated in favor of 'mdadm_udev'
'²' This hook is deprecated in favor of 'lvm2'
beisic ~ $ mkinitcpio -H kms
==> Help for hook 'kms':
Adds KMS and privacy screen drivers to the initramfs image. To minimize the
modules in the image, add the autodetect hook too.
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)
raccoon
Аватара пользователя
Сообщения: 15
Зарегистрирован: 11.08.2022

#

у меня на ноутбуке grub, efi, nvme. grub.cfg самописный, отображаются как загрузочные записи ( выбор linux/ windows ) так и лог загрузки.

«Load universe into cannon. Aim at brain. Fire.» ©

beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

ALiEN:initcpio
Спасибо за подсказку. Что делал с системой опишу здесь - может кому пригодится. Все делал на рельном железе, без использования виртуальных машин.
1. Установил пакет kexec-tools. При команде : # systemctl kexec , система "ругается" на два initrd в загрузчике - initramfs-linux.img и обновление микрокода.
2. В /etc/mkinitcpio.d/linux.preset добавил строку: ALL_microcode=(/boot/*-ucode.img) , а в /boot/loader/entries/arch.conf строку ## initrd /intel-ucode.img (закомментировал).
3. Установил пакет efifs и скопировал его (их 4 папки) в /boot/EFI/systemd/drivers/, для поддержки загрузки UEFI-драйверов файловых систем загрузчиком systemd-boot
4. При команде; # mkinitcpio -P ошибок нет и success.
5. При обновлении системы и команде: # systemctl kexec ,ПК перегружается за timeout 5 указанных в /boot/loader/conf.
6. Загрузочных записей так и нет, но в bootctl list винда есть.
beisic ~ $   bootctl list
         type: Boot Loader Specification Type #1 (.conf)
        title: arch (default)
           id: arch.conf
       source: /boot//loader/entries/arch.conf
        linux: /boot//vmlinuz-linux
       initrd: /boot//initramfs-linux.img
      options: root=/dev/nvme0n1p2 rw

         type: Automatic
        title: Windows Boot Manager
           id: auto-windows
       source: /sys/firmware/efi/efivars/LoaderEntries-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f

         type: Automatic
        title: Reboot Into Firmware Interface
           id: auto-reboot-to-firmware-setup
       source: /sys/firmware/efi/efivars/LoaderEntries-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f
 
SerW
Сообщения: 22
Зарегистрирован: 27.06.2023

#

У меня загрузка отображается, но всё сплошь в белом тексте.
Нет привычных мне зеленых и красных выделений, как в Дебиан.
Можно ли сделать так, чтобы был сплэш скрин при загрузке?
Как это сделано в Федора.
[DragonSerW@alarm ~]$ inxi -b
System:
  Host: alarm Kernel: 5.10.110-6-aarch64-orangepi5+ arch: aarch64 bits: 64
    Desktop: GNOME v: 45.1 Distro: Arch Linux ARM
Machine:
  Type: ARM System: Orange Pi 5 details: N/A
CPU:
  Info: 3x 4-core Model N/A [MCP AMP] speed (MHz): avg: 906
    min/max: 408/1800:2400
Graphics:
  Device-1: display-subsystem driver: rockchip_drm v: N/A
  Device-2: mali-bifrost driver: mali v: N/A
  Device-3: rk3588-dw-hdmi driver: dwhdmi_rockchip v: N/A
  Device-4: Logitech B525 HD Webcam driver: snd-usb-audio,uvcvideo type: USB
  Display: wayland server: X.org v: 1.21.1.9 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: N/A resolution: no compositor data
    resolution: 1920x1200
  API: OpenGL v: 4.5 compat-v: 3.0 vendor: panfrost v: N/A
    renderer: Mali-G610 (Panfrost)
Network:
  Device-1: Broadcom driver: pcieh
  Device-2: rk3588-gmac driver: rk_gmac_dwmac
  Device-3: wlan-platdata driver: wlan_platdata
Drives:
  Local Storage: total: 262.14 GiB used: 8.72 GiB (3.3%)
Info:
  Processes: 293 Uptime: 1h 27m Memory: total: N/A available: 15.6 GiB
  used: 1.9 GiB (12.2%) Shell: Bash inxi: 3.3.31
[DragonSerW@alarm ~]$ 

Сергей Швайко, DragonSerW

beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

Не знаю, что повлияло из установленных пакетов, но
ALiEN:загрузка очень быстро проскакивает
и сначала думал, что "показалось". "Проскакивает" очень быстро, успеваешь заметить, что это строки, а разобрать что-то ...
Затем решил запустить винду через выбор диска по F12-boot menu. Выйти в BIOS-UEFI тоже не могу.
Замену "клавы", вытаскивание диска-NVMe - сделать всегда успею.
По https://man.archlinux.org/man/bootctl.1 через systemctl reboot --boot-loader-entry=ID решил "зайти" в винду. По sudo blkid получил все UUID и PARTUUID всех дисков.
Команда bootctl выдала версию Product: systemd-boot 244.3-1-arch.
А systemd уже стоит Version: 254.6-2
На команду :
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

beisic ~ $ sudo bootctl update
Skipping "/boot/EFI/systemd/systemd-bootx64.efi", same boot loader version in place already.
Skipping "/boot/EFI/BOOT/BOOTX64.EFI", same boot loader version in place already.
В арчвики читал в примечании, что версия systemd-boot не влияет на загрузку, но автоматом обновлять можно только с 250 версии.
Еще вариант: установка пакета extra/edk2-shell 202308-3 .
P.S. Пишу уже который раз. Но при нажатии на "предосмотр" - "выкидывает" без сохранения текста. Поэтому текст отправляю сразу "без проверки".
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

Процесс загрузки системы отображается при обновлении сисемы и : sudo systemctl kexec,
при обычном reboot - ничего не отображается, сразу окно входа.
Проверил :
beisic ~ $    systemctl --failed
  UNIT LOAD ACTIVE SUB DESCRIPTION
0 loaded units listed. 
И на ошибки:
beisic ~ $     journalctl -b -p err
ноя 22 13:06:02 pc kernel: x86/cpu: SGX disabled by BIOS.
ноя 22 13:06:02 pc kernel: RETBleed: WARNING: Spectre v2 mitigation leaves CPU vulnerable to RETBleed attacks, data leaks possible!
ноя 22 13:06:02 pc kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.PRT0._GTF.DSSP], AE_NOT_FOUND (20230628/psargs-330)
ноя 22 13:06:02 pc kernel: ACPI Error: Aborting method \_SB.PCI0.SAT0.PRT0._GTF due to previous error (AE_NOT_FOUND) (20230628/psparse-529)
ноя 22 13:06:02 pc kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.PRT0._GTF.DSSP], AE_NOT_FOUND (20230628/psargs-330)
ноя 22 13:06:02 pc kernel: ACPI Error: Aborting method \_SB.PCI0.SAT0.PRT0._GTF due to previous error (AE_NOT_FOUND) (20230628/psparse-529)
ноя 22 13:06:02 pc kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.PRT2._GTF.DSSP], AE_NOT_FOUND (20230628/psargs-330)
ноя 22 13:06:02 pc kernel: ACPI Error: Aborting method \_SB.PCI0.SAT0.PRT2._GTF due to previous error (AE_NOT_FOUND) (20230628/psparse-529)
ноя 22 13:06:02 pc kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.PRT3._GTF.DSSP], AE_NOT_FOUND (20230628/psargs-330)
ноя 22 13:06:02 pc kernel: ACPI Error: Aborting method \_SB.PCI0.SAT0.PRT3._GTF due to previous error (AE_NOT_FOUND) (20230628/psparse-529)
ноя 22 13:06:02 pc kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.PRT2._GTF.DSSP], AE_NOT_FOUND (20230628/psargs-330)
ноя 22 13:06:02 pc kernel: ACPI Error: Aborting method \_SB.PCI0.SAT0.PRT2._GTF due to previous error (AE_NOT_FOUND) (20230628/psparse-529)
ноя 22 13:06:02 pc kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.PRT3._GTF.DSSP], AE_NOT_FOUND (20230628/psargs-330)
ноя 22 13:06:02 pc kernel: ACPI Error: Aborting method \_SB.PCI0.SAT0.PRT3._GTF due to previous error (AE_NOT_FOUND) (20230628/psparse-529)
ноя 22 13:06:02 pc kernel: usb 1-11: device not accepting address 5, error -71
ноя 22 13:06:02 pc kernel: usb 1-11: device descriptor read/all, error -71
ноя 22 13:06:03 pc kernel: usb 1-11: can't set config #1, error -71
ноя 22 13:06:10 pc sddm-helper[519]: gkr-pam: unable to locate daemon control file 
Но при этом, система прекрасно работает. Никаких проблем. Единственный минус - не могу выйти в БИОС-УЕФИ и загрузиться в винду. Вот информация о системе:
beisic ~ $  inxi -Fxz
System:
  Kernel: 6.6.2-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: Xfce v: 4.18.1 Distro: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: B250M-D3H v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: B250M-D3H-CF v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F7 date: 07/06/2017
CPU:
  Info: quad core model: Intel Core i5-7600 bits: 64 type: MCP arch: Kaby Lake
    rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 800 min/max: 800/4100 cores: 1: 800 2: 800 3: 800 4: 800
    bogomips: 28009
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Gigabyte driver: i915 v: kernel
    arch: Gen-9.5 bus-ID: 00:02.0
  Display: x11 server: X.Org v: 21.1.9 driver: X: loaded: intel
    unloaded: modesetting dri: i965 gpu: i915 resolution: 2560x1080~60Hz
  API: Vulkan v: 1.3.269 drivers: intel surfaces: xcb,xlib devices: 1
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  API: ALSA v: k6.6.2-arch1-1 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.85 status: off
  Server-3: PulseAudio v: 16.1 status: active
Network:
  Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 851.12 GiB used: 76.09 GiB (8.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 250GB
    size: 232.89 GiB temp: 36.9 C
  ID-2: /dev/sda model: SSD32G size: 29.5 GiB
  ID-3: /dev/sdb vendor: Samsung model: SSD 850 EVO 120GB size: 111.79 GiB
  ID-4: /dev/sdc vendor: Teclast model: 512GB A850 size: 476.94 GiB
Partition:
  ID-1: / size: 226.32 GiB used: 76 GiB (33.6%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot size: 252 MiB used: 88.4 MiB (35.1%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: partition size: 1.5 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p3
  ID-2: swap-2 type: zram size: 15.16 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 39.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 212 Uptime: 1h 7m Memory: total: 32 GiB note: est.
  available: 30.32 GiB used: 3.88 GiB (12.8%) Init: systemd Compilers:
  gcc: 13.2.1 clang: 16.0.6 Packages: 1128 Shell: Bash v: 5.2.15 inxi: 3.3.31 
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

Для загрузки с другого диска (в винду) перепробовал несколько вариантов.
Из арча путь до файла bootmgfw.efi :
/boot/EFI/Microsoft/Boot/
При монтировании диска, где винда :
/run/media/beisic/D0623D37623D241E/Windows/Boot/EFI/
Каталоги и файлы совпадают (только в первом случае Microsoft, во втором Windows).
Согласно wiki командой blkid нужно узнать PARTUUID раздела, на котором находится целевой EFI-файл винды. Затем перегрузиться в EFI Shell и узнать (по PARTUUID) командой
map FS alias раздела для создания в арче файла windows.nsh.
beisic ~ $ bootctl list
         type: Boot Loader Specification Type #1 (.conf)
        title: arch (default) (selected)
           id: arch.conf
       source: /boot//loader/entries/arch.conf
        linux: /boot//vmlinuz-linux
       initrd: /boot//initramfs-linux.img
      options: root=/dev/nvme0n1p2 rw add_efi_memmap

         type: Automatic
        title: Windows Boot Manager
           id: auto-windows
       source: /sys/firmware/efi/efivars/LoaderEntries-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f

         type: Automatic
        title: EFI Shell
           id: auto-efi-shell
       source: /sys/firmware/efi/efivars/LoaderEntries-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f

         type: Automatic
        title: Reboot Into Firmware Interface
           id: auto-reboot-to-firmware-setup
       source: /sys/firmware/efi/efivars/LoaderEntries-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f
Командой: $ systemctl reboot --boot-loader-entry=auto-efi-shell
Комп перегружается, запускается - но монитор не выводит никакого изображения.
Кнопкой БП выкл\вкл ПК загружается в арч. Да и предыдущие попытки ( с подстановкой различных UUID, UPARTUUID, идентификатора диска по root@pc beisic]# fdisk -l /dev/sdb2
и т.д. и т.п.) те же самые - ПК работает, но черный экран, по БП, обратно в арч.
Возможно "слетел" БИОС - замена клавы, нажатия по del и F2 - результатов не принесли : так же ПК работает, но экран ничего не выводит, и опять БП и арч.
Будет время - извлеку NVMe и, возможно, выйду в БИОС (свежую версию 18 года уже скачал с сайта) и поставлю "свежую" прошивку.
vall
Аватара пользователя
Администрация
Сообщения: 517
Зарегистрирован: 09.08.2022

#

В сообщении выше спрятал "простынь" вывода с помощью форматирования текста.
Пожалуйста, используйте возможности форума самостоятельно. Как делали это в своих предыдущих постах.
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

vall спасибо, и вид поста лучше стал. Может и название подправить ? При запуске системного вызова kexec процесс загрузки, всё-же, появился :
beisic ~ $     systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @2.001s
└─multi-user.target @1.997s
  └─ntpd.service @1.940s +53ms
    └─network.target @1.912s
      └─NetworkManager.service @1.547s +363ms
        └─basic.target @1.545s
          └─dbus-broker.service @1.523s +19ms
            └─dbus.socket @1.506s
              └─sysinit.target @1.501s
                └─systemd-update-utmp.service @1.472s +26ms
                  └─systemd-tmpfiles-setup.service @1.371s +84ms
                    └─local-fs.target @1.368s
                      └─tmp.mount @1.320s +36ms
                        └─swap.target @1.301s
                          └─dev-zram0.swap @1.202s +94ms
                            └─systemd-zram-setup@zram0.service @1.153s +37ms
                              └─dev-zram0.device @1.085s 
Отключить системный вызов kexec (есть мнение - может использоваться для замены работающего ядра) в файле # /etc/sysctl.d/99-sysctl.conf добавить запись :
 kernel.kexec_load_disabled=1
https://lwn.net/Articles/580269/
vall
Аватара пользователя
Администрация
Сообщения: 517
Зарегистрирован: 09.08.2022

#

beisic:Может и название подправить ?
Это Ваша ветка -- сами принимайте решение.

Для этого достаточно внести изменение в первое сообщение, открывающее обсуждение. В заголовок "Тема".
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

Допишу окончание этой проблемы (или истории). Очень коротко.
Вскрыл ПК, отключил NVMe и ПК окончательно "отказал" в загрузке.
Вытащил SSD с видой. Вставил NVIDIA GeForce GTX 1050 (без доп.питания).
Обновил БИОС до версии F10. Каким-то "чудом" в биосе прописана загрузка с винды.
Через флешку с арчисо, чрутнулся в систему и /boot "вычистил" от остатков винды.
Теперь ПК грузится только через "режим" UEFI. В биосе "режим" загрузки винды остался.
Через встроенное видеоядро "мамки" ПК "не показывает" экран, только через видеокарту.
Процесс загрузки и бут-меню все теперь есть.
Через sudo systemctl kexec ПК перегружается и "виснет".
Обычный reboot на 0,112s больше :
  beisic ~ $    systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @2.113s
└─multi-user.target @2.113s
  └─ntpd.service @2.087s +26ms
    └─network.target @2.066s
      └─NetworkManager.service @1.761s +304ms
        └─basic.target @1.760s
          └─dbus-broker.service @1.743s +15ms
            └─dbus.socket @1.742s
              └─sysinit.target @1.740s
                └─systemd-update-utmp.service @1.717s +23ms
                  └─systemd-tmpfiles-setup.service @1.608s +98ms
                    └─local-fs.target @1.585s
                      └─boot.mount @1.360s +223ms
                        └─systemd-fsck@dev-disk-by\x2duuid-768B\x2d2FE1.service @1.261s +75ms
                          └─dev-disk-by\x2duuid-768B\x2d2FE1.device @1.227s 
Прошу отметить тему как "РЕШЕНО"
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

beisic ~ $ lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 Display controller: Intel Corporation HD Graphics 630 (rev 04)
	DeviceName:  Onboard IGD
	Subsystem: Gigabyte Technology Co., Ltd HD Graphics 630
	Kernel driver in use: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050] (rev a1)
	Subsystem: Gigabyte Technology Co., Ltd GP107 [GeForce GTX 1050]
	Kernel driver in use: nouveau
	Kernel modules: nouveau 
Для включения "встроенного видеоядра "мамки" ПК " в БИОСе нужно активировать режим
Onboard IGD.
beisic
Сообщения: 35
Зарегистрирован: 16.09.2022

#

beisic:Через sudo systemctl kexec ПК перегружается и "виснет".
Решение:
$ sudo kexec -l /boot/vmlinuz-linux --initrd=/boot/initramfs-linux.img --reuse-cmdline
$ sudo systemctl kexec
Ответить