Дефектные обновления [Core], [Extra]

Вопросы по менеджеру пакетов и обновлениям
SmiGes
Сообщения: 3
Зарегистрирован: 10.08.2022

#

По традиции прошлого форума описываем проблемы возникшие после обновлений пакетов из веток [Core], [Extra],[Community], а так же способы их решения.
willrock
Сообщения: 12
Зарегистрирован: 15.08.2022

#

Доброе утро. Ошибка pacman при обновлении.

[nik@archlinux ~]$ sudo pacman -Syu
ошибка: ошибка GPGME: Нет данных
:: Обновление баз данных пакетов...
 core                            158,3 KiB   184 KiB/s 00:01 [################################] 100%
 extra                          1827,0 KiB  1015 KiB/s 00:02 [################################] 100%
 community is up to date
 multilib                        176,3 KiB   392 KiB/s 00:00 [################################] 100%
ошибка: ошибка GPGME: Нет данных
ошибка: failed to synchronize all databases (непредвиденная ошибка)
willrock
Сообщения: 12
Зарегистрирован: 15.08.2022

#

Покопался на буржуйском форуме, нашел похожие вопросы по GPGME error: No data. Команда

sudo rm -r /var/lib/pacman/sync/ 

исправила проблему.

vall
Аватара пользователя
Администрация
Сообщения: 520
Зарегистрирован: 09.08.2022

#

Доброе,

было бы неплохо использовать тег код (как это сделано в предыдущем сообщении) в найденном решении Вашего вопроса и указать источник на bbs. Очевидно, что это https://bbs.archlinux.org/viewtopic.php?id=268087

Так будет удобнее решить аналогичную проблему другим пользователям. Если они в будущем столкнуться с подобным.

Вопрос, насколько смог понять, связан с зеркалами для обновления. И периодически всплывает на bbs.

P.S. Чуть подправил сообщение выше -- вставка кода.

willrock
Сообщения: 12
Зарегистрирован: 15.08.2022

#

Спасибо за замечание. Учту на будущее. Вот https://bbs.archlinux.org/viewtopic.php?id=276095

vall
Аватара пользователя
Администрация
Сообщения: 520
Зарегистрирован: 09.08.2022

#

Вам спасибо. Обозначили проблему и сами же нашли ответ. Наверняка эта информация пригодится.

Хотя, строго говоря, проблема в невозможности обновления. А не в проблемах с конкретными пакетами (что по задумке обсуждается здесь). Другими словами вполне можно было сделать отдельную ветку.

Зато "сухая" ветка благодаря Вам ожила) Оставим всё как есть.

ugras
Аватара пользователя
Сообщения: 73
Зарегистрирован: 11.09.2022

#

Сегодня прилетело сразу два дефектных обновления:

1. networkmanager 1.40.2-1: собственно, возможно и не дефект, а особенность, с которой нужно разбираться, но замечена задержка старта сети на несколько секунд при запуске системы. Замечено потому, что модули waybar,которым требуется сеть, на запуске системы падают в ошибку из-за её отсутствия.
Откат на 1.40.0-1 решил проблему.

2. xorg-xwayland 22.1.4-1: проблема с rofi в среде sway, причём весьма странная. Один раз rofi отрабатывает нормально, затем окно появляется и сразу исчезает, как-будто было нажатие [Enter]. Если перейти затем к окну firefox, то обнаруживается действительно эффект залипания клавиши, т.е. идёт постоянный перевод строки, пока не нажмёшь [esc]. Затем один раз rofi отрабатывает нормально и снова всё повторяется.
Откат на 22.1.3-1 решил проблему.

Проблемы проявлялись одинаково на двух компьютерах с идентичными системами на sway. Пока поставил пакеты в игнор.
vall
Аватара пользователя
Администрация
Сообщения: 520
Зарегистрирован: 09.08.2022

#

Похоже, что вопросы специфичекские для sway.
Например, в KDE networkmanager после обновления работает без задержек.
ugras
Аватара пользователя
Сообщения: 73
Зарегистрирован: 11.09.2022

#

Конечно, KDE загружается не так быстро и networkmanager успевает, а sway влетает быстрее него, но это проблема пустяковая, можно вписать в модули sleep на пару секунд, а вот xorg-xwayland 22.1.4-1 крашит приложение, и это уже никуда не годится.
vasek
Сообщения: 358
Зарегистрирован: 31.08.2022

#

ugras:а вот xorg-xwayland 22.1.4-1 крашит приложение
Проблема скорее всего не в xorg-xwayland , а в приложении rofi .... не пробовал rofi-wayland-git из AUR? .... Посмотри это
rofi и networkmanager не использую ... проблем в sway не замечаю.

Ошибки не исчезают с опытом - они просто умнеют

ugras
Аватара пользователя
Сообщения: 73
Зарегистрирован: 11.09.2022

#

vasek:не пробовал rofi-wayland-git из AUR?
Благодарю за наводку!
Этот пакет не ставится, но поставился rofi-lbonn-wayland-git
❯ rofi -v
Version: 1.7.5+wayland1-38-gfd0ef6bc (makepkg)
xorg-xwayland обновил, работает нормально.
RusWolf
Аватара пользователя
Сообщения: 151
Зарегистрирован: 16.08.2022

#

ugras:KDE загружается не так быстро
Так же быстро.
Да и сервис networkmanager стартует намного раньше, чем KDE.
51ms NetworkManager.service
Это так, на всякий случай.

Arch Linux x86-64 на BTRFS

ugras
Аватара пользователя
Сообщения: 73
Зарегистрирован: 11.09.2022

#

У меня сеть появляется примерно через 1 сек. после загрузки панели. Ничего страшного, переписал скрипты модулей, чтобы ждали пинг.
vall
Аватара пользователя
Администрация
Сообщения: 520
Зарегистрирован: 09.08.2022

#

Обновление nvidia 520.56.06-4 -> 520.56.06-7 вызывает следующую проблему для ядра linux. Смотрим окончание записи.
(5/8) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
==> Starting build: 5.15.75-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [plymouth]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
==> Starting build: 5.15.75-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [plymouth]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 6.0.2-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [plymouth]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [fsck]
==> ERROR: module not found: `nvidia'
==> ERROR: module not found: `nvidia_modeset'
==> ERROR: module not found: `nvidia_uvm'
==> ERROR: module not found: `nvidia_drm'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 6.0.2-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [plymouth]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [fsck]
==> ERROR: module not found: `nvidia'
==> ERROR: module not found: `nvidia_modeset'
==> ERROR: module not found: `nvidia_uvm'
==> ERROR: module not found: `nvidia_drm'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> WARNING: errors were encountered during the build. The image may not be complete.
ошибка: не удалось корректно выполнить команду
Пока гружусь с lts-ядром. Возможно уже "традиционная" для меня проблема с зеркалом. Сейчас проверять некогда. На всякий случай предупредил, чтобы коллеги обратили внимание.
RusWolf
Аватара пользователя
Сообщения: 151
Зарегистрирован: 16.08.2022

#

vall: ==> ERROR: module not found: `nvidia'
==> ERROR: module not found: `nvidia_modeset'
==> ERROR: module not found: `nvidia_uvm'
==> ERROR: module not found: `nvidia_drm'
Ну нет модулей ядра для ядра 6.0.2, потому что nvidia-520.56.06-7, собрано для ядра 6.0.5, который сейчас в core, ещё с 26-го числа.

Arch Linux x86-64 на BTRFS

vall
Аватара пользователя
Администрация
Сообщения: 520
Зарегистрирован: 09.08.2022

#

Спасибо, разобрался. Непонятно было отсутствие модулей, а вот сопоставить с версией ядра не было времени. И не догадался. Хотя проверил пару зеркал (после своего сообщения) и на обоих лежало актуальным ядро 6.0.2-arch1-1. Иногда бывает такое рассогласование.

linux 6.0.5.arch1-1 Last Updated: 2022-10-28 07:27 UTC другими словами 28 октября всё же, хотя Signature Date: 2022-10-26 15:59 UTC.

Сегодня всё прилетело как положено.
vantu5z
Аватара пользователя
Сообщения: 17
Зарегистрирован: 05.09.2022

#

При обновлении ядра до linux 6.0.9-arch1-1 отвалился bluetooth, но wifi работает. Пока откатился на 6.0.8-arch1-1 до выяснения причин.
Ноут: ProBook 4530s
Карточка wifi + bluetooth:
25:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 [Rainbow Peak] (rev 34)
RusWolf
Аватара пользователя
Сообщения: 151
Зарегистрирован: 16.08.2022

#

vantu5z: При обновлении ядра до linux 6.0.9-arch1-1 отвалился bluetooth, но wifi работает.
Драйвер используется из ядра?

Arch Linux x86-64 на BTRFS

vantu5z
Аватара пользователя
Сообщения: 17
Зарегистрирован: 05.09.2022

#

RusWolf:Драйвер используется из ядра?
А как посмотреть?
lsmod | grep bt
ничего не выводит.
В понедельник буду разбираться.
sinclaus
Аватара пользователя
Сообщения: 47
Зарегистрирован: 27.08.2022

#

У меня ядро Linux pmm 6.0.9-arch1-1, проверил - БТ наушники работают.
Ответить