Установщик не видит nvme

Вопросы по встроенному инсталлятору
Ответить
Som3Us3rnam3
Сообщения: 3
Зарегистрирован: 31.10.2022

#

Всем доброго дня! При установке арча установщик нивкакую не хочет различать nvme ssd(Patriot scorch M.2). Самый цимес в том, что когда я установил арч на жёсткий диск(кой благо был), установленный арч уже видит nvme. Но хотелось бы установить арч на nvme. Подскажите, пожалуйста, в чём может быть проблема? Если нужна какая-либо информация - спрашивайте. Модель ноутбука Asus X509F.
vasek
Сообщения: 358
Зарегистрирован: 31.08.2022

#

Som3Us3rnam3:не хочет различать nvme ssd
Предоложу, что имеется Intel и работает технология RST (Rapid Storage Technology), наличие которой вызывает проблемы при установке Linux … (в режиме RST не отображается диск nvme).
Что рекомендуют? - зайти в BIOS и отключить RST (точне переключиться с RST на AHCI) ... после установки можно вернуть обратно ... но вот всегда ли это возможно, 100% уверенности нет.

EDIT 1 - в BIOS/UEFI эти настройки обычно скрыты - нужно перейти на главную закладку (main) и нажать Ctrl+S. … после перевода в AHCI mode, диск будет виден системой как обычный nvme … (RST - это типа RAID для nvme дисков, которые не каждый linux видит).

Ошибки не исчезают с опытом - они просто умнеют

Som3Us3rnam3
Сообщения: 3
Зарегистрирован: 31.10.2022

#

vasek:
Som3Us3rnam3:не хочет различать nvme ssd
Предоложу, что имеется Intel и работает технология RST (Rapid Storage Technology), наличие которой вызывает проблемы при установке Linux … (в режиме RST не отображается диск nvme).
Что рекомендуют? - зайти в BIOS и отключить RST (точне переключиться с RST на AHCI) ... после установки можно вернуть обратно ... но вот всегда ли это возможно, 100% уверенности нет.

EDIT 1 - в BIOS/UEFI эти настройки обычно скрыты - нужно перейти на главную закладку (main) и нажать Ctrl+S. … после перевода в AHCI mode, диск будет виден системой как обычный nvme … (RST - это типа RAID для nvme дисков, которые не каждый linux видит).
Спасибо, помогло! В биосе для жёсткого диска включил AHCI, всё заработало. Только после установки арча на nvme появилась проблема - сама система не загружается. Т.е. сам grub нормально загружается, появляется окно. После выбора загружаемой системы в grub - чёрный экран. Полазил по форумам, сказали поставить
nvme_load=YES
в
/etc/default/grub
, не помогло.
vasek
Сообщения: 358
Зарегистрирован: 31.08.2022

#

Som3Us3rnam3: ... помогло! В биосе для жёсткого диска включил AHCI, всё заработало. Только после установки арча на nvme появилась проблема - сама система не загружается. Т.е. сам grub нормально загружается, появляется окно. После выбора загружаемой системы в grub - чёрный экран.
А вот здесь уже нужен анализ, нужны логи ... чтобы понять причину ... без этого одни гадания.
Во 1-ых, с RST разобрался … но нужно было погуглить на эту тему и вышел бы на Intel VMD - возможно нужно было отключить еще и Vmd controller .... либо вместо этого попробовать прописать модуль vmd в initramfs и перегенирить ядро (если и это не поможет, то можно поиграться с параметром модуля nvme_core - nvme_core.default_ps_max_latency_us=(например, 5500 или 14000 или 52000) …. и другое - всего не опишешь (гугли)

Во 2-ых нужно попытаться загрузиться ручками из консоли Grub ... заодно проверишь все ли на месте и плюс к этому добавить логирование Grub, что поможет определить место затыка. Как это все делать описано на старом форуме (погугли)

PS - в части nvme_load=YES - не рекомендую использовать параметры загрузки, суть/назначение которых не прояснил.

EDIT -1 - а вообще с новыми технологиями nvme в новых железках у Linux есть проблемы.
И забыл отметить - все описанное выше при условии, что проблем с установленными видеодрайверами нет ...

EDIT 2 - хотя учитывая фразу
Som3Us3rnam3:После выбора загружаемой системы в grub - чёрный экран
видеодрайвер, скорее всего, не может быть причиной проблемы. ... нужно определить, что конкретно мешает загрузке ... и на каком этапе.
Если грубо и просто, то в части последнего этапа загрузки - загрузчик загружает в память образ ядра, которое инициализирует и подготавливает память, оборудование, монтирует корневой раздел для загрузки остальной системы. И если все нормально и ошибок нет, то после инициализации ядро передает управление процеcсу init (первому системному процессу с PID=1). В качестве процесса init Archlinux использует systemd.
Вот что ему не хватает и стоит выяснит. Начни с самого простого - пробуй определить примерное место затыка, для чего загрузись с параметрами
break=premount - приостановка процесса загрузки перед монтированием корневой ФС
break=postmount - приостановка процесса загрузки после монтирования корневой ФС
А вообще если никогда этим не интересовался, то это довольно трудная задача, всего не опишешь, нужно хорошо понимать, что делаешь и на каком этапе находишься ... все приходит с опытом .... и, конечно, нужно увеличить логирование для получения большей информации.

Ошибки не исчезают с опытом - они просто умнеют

vall
Аватара пользователя
Администрация
Сообщения: 519
Зарегистрирован: 09.08.2022

#

На устройство HP Laptop 15s-eq2001 (AMD Ryzen™ 5 5500U, PCIe® NVMe™ M.2 SSD) Arch Linux установился без всяких проблем; диск NVMe увидел сразу, без танцев с бубном.

Но существенная оговорка: устанавливал по классическому методу -- из командной строки.
MamkinHaker
Сообщения: 11
Зарегистрирован: 01.11.2022

#

Установщики не видят, если nvme c разметкой GPT , а флешка запущена не в UEFI.
Som3Us3rnam3
Сообщения: 3
Зарегистрирован: 31.10.2022

#

Всем спасибо большое, разобрался. Просто я немного криво систему установил, поэтому grub не мог загрузить ядро. Переустановил систему, всë заработало.
vall
Аватара пользователя
Администрация
Сообщения: 519
Зарегистрирован: 09.08.2022

#

Som3Us3rnam3:Всем спасибо большое, разобрался.
Тогда, пожалуйста, измените название темы в первом сообщении. Указав в начале [РЕШЕНО].
Zeon
Сообщения: 1
Зарегистрирован: 16.04.2023

#

vasek:
Som3Us3rnam3:не хочет различать nvme ssd
Предоложу, что имеется Intel и работает технология RST (Rapid Storage Technology), наличие которой вызывает проблемы при установке Linux … (в режиме RST не отображается диск nvme).
Что рекомендуют? - зайти в BIOS и отключить RST (точне переключиться с RST на AHCI) ... после установки можно вернуть обратно ... но вот всегда ли это возможно, 100% уверенности нет.

EDIT 1 - в BIOS/UEFI эти настройки обычно скрыты - нужно перейти на главную закладку (main) и нажать Ctrl+S. … после перевода в AHCI mode, диск будет виден системой как обычный nvme … (RST - это типа RAID для nvme дисков, которые не каждый linux видит).
Специально зарегистрировался что бы сказать спасибо тебе Vasek. 2 дня мучался с этой проблемой.
Ответить