[РЕШЕНО] tcl + tclx + linuxcnc-sim + bwidget

Браузеры, почтовые клиенты, офисные пакеты, файловые менеджеры, редакторы и т.п.
Ответить
lnx
Сообщения: 68
Зарегистрирован: 24.08.2022

#

Опять. Прилетело обновление tcl, что потянуло за собой пересборку tclx and linuxcnc-sim. Но затык - при борке linuxcnc проверяет факт установки bwidget, который установлен, но не обнаруживает его и все падает.
pacman -Qs bwidget
local/bwidget 1.9.16-1
    A suite of megawidgets for Tk

checking for __sincos... no
checking for tcl... /usr/lib/tclConfig.sh found
checking for tk... /usr/lib/tkConfig.sh found
checking whether to check for runtime dependencies... yes
checking for BWidget using /usr/bin/tclsh8.6... no
configure: error: BWidget not found!
install with "sudo apt-get install bwidget"
==> ОШИБКА: Произошел сбой в build().
    Прерывание...

Не удалось выполнить команду 'makepkg --force'.

Как преодолеть?
Последний раз редактировалось lnx 10.02.2023 17:36, всего редактировалось 3 раза.
vasek
Сообщения: 275
Зарегистрирован: 31.08.2022

#

lnx:Как преодолеть?
Если ставишь пакеты из AUR, то будь готов к решению проблем ... и в 1-ую очередь нужно зайти на AUR и посмотреть Latest Comments ... если проблему еще не описали другие, опиши сам .... и жди, что ответит разработчика.
Пользователи Arch, которые не используют данный левый софт, вряд ли смогут помочь тебе в этом.

PS - а проблема похоже уже описана - https://aur.archlinux.org/packages/linuxcnc-sim

Ошибки не исчезают с опытом - они просто умнеют

lnx
Сообщения: 68
Зарегистрирован: 24.08.2022

#

Припомнил, что сталкивался с аналогичной ситуацией с camotics https://aur.archlinux.org/packages/camotics-git и тогда сперва решил вопрос костылем https://forum.freecadweb.org/viewtopic. ... 25#p607025
ln -s /home/user/.cache/pikaur/build/camotics-git/src/camotics/build/camotics.so /usr/lib/python3.10/site-packages/

и затем разработчик пакета это сам поправил. Попробовал пойти по аналогии, но find никаких so не находит, есть лишь -
/usr/lib/tcl8.6/bwidget-1.9.16/demo/bwidget.xbm

Но в топике bwidget в Ауре, https://aur.archlinux.org/packages/bwidget, есть анализ проблемы (пакет разворачивается без прав юзеров даже открыать директорий) и, соответственно, есть решение -
chmod -R o+rX /usr/lib/tcl8.6/bwidget-1.9.16

Этот этап прошли, но уткнулся в следующий -
checking python version... OK
checking version of python libraries... python2.7
checking match between tk and Tkinter versions... 8.6
checking location of Python header files... /usr/include/python2.7
checking for Python headers... -I/usr/include/python2.7
checking for Python libraries... -ldl
checking whether the Boost::Python headers are available... yes
checking for boost::python shared library... 
configure: error: boost::python is required to build LinuxCNC
==> ОШИБКА: Произошел сбой в build().
    Прерывание...
по памяти из https://archlinux.org.ru/forum/topic/20584/?page=2 покамест пошел пересобирать boost-python2 - не помогло.
vasek
Сообщения: 275
Зарегистрирован: 31.08.2022

#

Насколько я понимаю, большинство прог из AUR тебе нужны в основном для своей основной работы.
Если это так, то не проще ли будет поступить следующим образом:
- создать на диске дополнительный раздел
- создать на этом разделе клон работающей системы (конечно же с работающими програми)
- обновлять эту систему-клон 1-2 раза в год и только в случае работоспособности основной системы (под обновлением имею ввиду клонирование, точнее, простое копирование).
А если основаная система заимела проблемы с нужными програми, то можно спокойно выполнять нужные работы из системы-клон.
После решения проблем в основной системе можно выполнить и клонирование.
Проблем будет на много меньше. Клонирование системы займет максимум минут 30, а если без документов, не входящих в систему, то и того меньше.

Ошибки не исчезают с опытом - они просто умнеют

lnx
Сообщения: 68
Зарегистрирован: 24.08.2022

#

lnx: по памяти из https://archlinux.org.ru/forum/topic/20584/?page=2 покамест пошел пересобирать boost-python2 - не помогло.
а вот не надо было мне скупиться, надо было персобрать boost-python2 + boost-python2-libs и все починилось. Ох уж этот коварный tcl, не в первый раз его обновление вредит.
lnx
Сообщения: 68
Зарегистрирован: 24.08.2022

#

Блин. Снова. Что-то из прилетевшего поломало.
Пересобрал boost-python2 bwidget tclx boost-python2-libs --rebuild
Linuncnc при пересборке стал требовать python-gtk2, как у нас такой пакет называется?
lnx
Сообщения: 68
Зарегистрирован: 24.08.2022

#

checking for python pango and cairo modules... Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/usr/lib/python2.7/site-packages/cairo/__init__.py", line 1, in <module>
from ._cairo import * # noqa: F401,F403
ImportError: /usr/lib/python2.7/site-packages/cairo/_cairo.so: undefined symbol: cairo_tee_surface_index
no
configure: error: Python pango and cairo modules not found!
install with "sudo apt-get install python-gtk2"
==> ОШИБКА: Произошел сбой в build().
Прерывание...

Не удалось выполнить команду 'makepkg --force'.
:: Попробовать восстановить?
[R] повторить сборку


В зависимостях пкбилда такого пакета нет (был бы - сборка бы и не запускалась)
lnx
Сообщения: 68
Зарегистрирован: 24.08.2022

#

а может это опять что-то с месой в последние дни было?
lnx
Сообщения: 68
Зарегистрирован: 24.08.2022

#

Вчера были приняты обновления -
 фев  9 00:44 qt5-base-5.15.8+kde+r181-1-x86_64.pkg.tar.zst
 фев  9 01:26 zsh-5.9-3-x86_64.pkg.tar.zst.sig
 фев  9 01:26 zsh-5.9-3-x86_64.pkg.tar.zst
 фев  9 02:16 lib32-cairo-1.17.8-2-x86_64.pkg.tar.zst.sig
 фев  9 02:16 lib32-cairo-1.17.8-2-x86_64.pkg.tar.zst
 фев  9 02:16 cairo-1.17.8-2-x86_64.pkg.tar.zst.sig
 фев  9 02:16 cairo-1.17.8-2-x86_64.pkg.tar.zst
 фев  9 02:28 aom-3.6.0-1-x86_64.pkg.tar.zst.sig
 фев  9 02:28 aom-3.6.0-1-x86_64.pkg.tar.zst
 фев  9 02:29 texinfo-7.0.2-2-x86_64.pkg.tar.zst.sig
 фев  9 02:29 texinfo-7.0.2-2-x86_64.pkg.tar.zst
 фев  9 15:23 libgusb-0.4.5-1-x86_64.pkg.tar.zst.sig
 фев  9 15:23 libgusb-0.4.5-1-x86_64.pkg.tar.zst
 фев  9 16:20 zvbi-0.2.40-1-x86_64.pkg.tar.zst.sig
 фев  9 16:20 zvbi-0.2.40-1-x86_64.pkg.tar.zst
 фев  9 16:38 lib32-sdl2-2.26.3-1-x86_64.pkg.tar.zst.sig
 фев  9 16:38 lib32-sdl2-2.26.3-1-x86_64.pkg.tar.zst
 фев  9 22:23 libxfce4ui-4.18.2-1-x86_64.pkg.tar.zst
 фев  9 22:23 libxfce4ui-4.18.2-1-x86_64.pkg.tar.zst.sig
 фев  9 22:53 python-zipp-3.13.0-1-any.pkg.tar.zst
 фев  9 23:08 python-zipp-3.13.0-1-any.pkg.tar.zst.sig
 фев  9 23:23 python-tenacity-8.2.1-1-any.pkg.tar.zst
 фев  9 23:23 python-tenacity-8.2.1-1-any.pkg.tar.zst.sig


как раз словой cairo было в ругани, вопрос решился даунгрейдом -

downgrade lib32-cairo cairo
Ответить